2012-12-26

I'm stuck, probably overlooking some configuration setting, hope you can help:

I've loaded OpenWRT on a TP-LINK WR703N, all is working as expected over wired Ethernet connection.
My initial setup without wifi on WR703N looks like this:

PC===Router(mywifi)---                       ===: wired Ethernet
||                                             ---: wifi
+===WR703N

TestMode: Switch on wifi on WR703N, with wireless mode ap and test ssid: From Laptop able to connect to the device over wifi with test ssid and can ssh into MyDevice ok. Plugging/unplugging wired Ethernet has no impact on the ssh session over wifi. When wired Ethernet is plugged in I can also ssh into MyDevice from the PC. So is what I expect: 2 independent network interface, both able to take ssh sessions.

PC===Router(mywifi)---                                     ===: wired Ethernet
||                                                           ---: wifi(ssid)
+===WR703N(test)---Laptop(test)

FinalMode: Then I set wireless to connect to mywifi network as client, mode to sta, mywifi ssid and encryption psk2 with key of mywifi network: Now I cannot ssh to device over wifi anymore. Why not?
When I connect Ethernet cable I can ssh into MyDevice both from Laptop and PC. I expect the Laptop actually uses the mywifi--Router--WR703N path to connect.

PC===Router(mywifi)----------------+                              ===: wired Ethernet
||                                   |                                   ---: wifi(ssid)
+       WR703N(mywifi)---+----Laptop(mywifi)

Guess it has something to do with the WR703N not connecting to mywifi properly as client?
But what am I doing wrong? Appreciate your help!

Greetings, Kurantje

Network config file looks like this:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option hostname 'MyDevice'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.9'
option netmask '255.255.255.0'
option gateway '192.168.1.2'
option dns '192.168.1.2'

My wireless config file looks like this:
config wifi-device  radio0
option type     mac80211
option channel  auto
option hwmode   11ng
option path     'platform/ar933x_wmac'
option htmode   HT20
list ht_capab   SHORT-GI-20
list ht_capab   SHORT-GI-40
list ht_capab   RX-STBC1
list ht_capab   DSSS_CCK-40

config wifi-iface
option device   radio0
option network  lan
#    option mode     ap         --> TestMode has this uncommented, FinalMode has this commented
option mode     sta         --> TestMode has this commented, FinalMode has this uncommented
#    option ssid     test          --> TestMode has this uncommented, FinalMode has this commented
option ssid     mywifi       --> TestMode has this commented, FinalMode has this uncommented
option encryption psk2
option key      mywifi-key

Show more