I am trying to simulate a PBX to VoIP gateway to ITSP.
Since I don't have a PBX, I built a cucme router and want to connect it to another cucme over a t1 connection. the other router will then send it out to the ITSP. I can not call between the 2 routers. Anyone want to take a shot at this? I will post both configs momentarily. I scrubbed some stuff but it is a lab setup, so not too much on it.
EDIT: Said I could call to the ITSP but that is only from the gateway router, there for irrelevant.
ITSP GATEWAY
Code:
!
card type t1 0 0
card type t1 0 1
logging message-counter syslog
!
no aaa new-model
network-clock-participate wic 0
no network-clock-participate wic 1
!
no dot11 syslog
ip source-route
!
!
ip cef
!
!
ip name-server 8.8.8.8
no ipv6 cef
!
multilink bundle-name authenticated
!
!
isdn switch-type primary-ni
!
!
voice service voip
allow-connections sip to sip
fax protocol cisco
sip
!
voice-card 0
!
archive
log config
hidekeys
!
controller T1 0/0/0
clock source internal
cablelength short 110
pri-group timeslots 1-24
description ***UPLINK TO ITSP GATEWAY RTR***
!
controller T1 0/0/1
cablelength long 0db
!
controller T1 0/1/0
cablelength long 0db
!
controller T1 0/1/1
cablelength long 0db
!
interface FastEthernet0/0
ip address 192.168.1.250 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:23
no ip address
encapsulation hdlc
no logging event link-status
isdn switch-type primary-ni
isdn timer T306 30000
isdn timer T310 40000
isdn timer T321 30000
isdn protocol-emulate network
isdn incoming-voice voice
isdn guard-timer 1000
isdn send-alerting
no fair-queue
no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
!
!
control-plane
!
!
voice-port 0/0/0:23
no non-linear
playout-delay maximum 120
playout-delay nominal 15
playout-delay minimum low
busyout monitor action shutdown
busyout monitor FastEthernet0/0
!
voice-port 0/2/0
station-id name Javin
station-id number 1001
caller-id enable
!
voice-port 0/2/1
station-id name Javin
station-id number 2001
caller-id enable
!
voice-port 0/2/2
!
voice-port 0/2/3
!
voice-port 0/3/0
!
voice-port 0/3/1
!
!
!
!
!
dial-peer voice 1001 pots
destination-pattern 1001
port 0/2/0
!
dial-peer voice 2001 pots
destination-pattern 2001
port 0/2/1
!
dial-peer voice 1 voip
description *** 10 Digit Calls ***
shutdown
destination-pattern [2-9]..[2-9]......
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 2 voip
description *** 11 Digit Calls ***
shutdown
destination-pattern 1[2-9]..[2-9]......
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 3 voip
description *** Lab Extensions ***
shutdown
destination-pattern 7......
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 100 pots
description *** Incoming Dial-Peer ***
incoming called-number .
port 0/2/1
!
dial-peer voice 11 pots
description *** 10 Digit Calls ***
destination-pattern [2-9]..[2-9]......
no digit-strip
port 0/0/0:23
!
dial-peer voice 12 pots
description *** 11 Digit Calls ***
destination-pattern 1[2-9]..[2-9]......
no digit-strip
port 0/0/0:23
!
dial-peer voice 13 pots
description *** Lab Extensions ***
destination-pattern 7......
no digit-strip
port 0/0/0:23
!
!
sip-ua
credentials username **** password **** realm sip-ua.com
authentication username **** password ****
registrar dns:proxy.sip-ua.com expires 60
sip-server dns:proxy.sip-ua.com
!
!
!
telephony-service
max-ephones 24
max-dn 48
ip source-address 192.168.1.250 port 2000
ip qos dscp af31 signal
auto assign 1 to 48
timeouts interdigit 2
system message Portland Site (PBX)
url services http://phone-xml.berbee.com/menu.xml
max-conferences 8 gain -6
web admin system name **** password ****
dn-webedit
time-webedit
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn 1 dual-line
number 5035550001
label PDX Phone 1
name PDX Phone 1
!
!
ephone-dn 2 dual-line
number 5035550002
label PDX Phone 2
name PDX Phone 2
!
!
ephone 1
device-security-mode none
description PDX Phone 1
mac-address 38EA.A75E.23A3
type CIPC
button 1:1
!
!
!
ephone 2
device-security-mode none
description PDX Phone 2
mac-address 000C.2949.E4CA
type CIPC
button 1:2
!
!
!
line con 0
line aux 0
line vty 0 4
login local
line vty 5 15
login local
!
scheduler allocate 20000 1000
ntp server 64.250.229.100
end
Router# show controller t1
T1 0/0/0 is up.
Applique type is Channelized T1
Cablelength is short 110
Description: ***UPLINK TO ITSP GATEWAY RTR***
No alarms detected.
alarm-trigger is not set
Soaking time: 3, Clearance time: 10
AIS State:Clear LOS State:Clear LOF State:Clear
Version info Firmware: 20100222, FPGA: 13, spm_count = 0
Framing is ESF, Line Code is B8ZS, Clock Source is Internal.
CRC Threshold is 320. Reported from firmware is 320.
Data in current interval (533 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
103 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
103 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
Total Data (last 24 hours)
5997 Line Code Violations, 13 Path Code Violations,
44333 Slip Secs, 0 Fr Loss Secs, 2 Line Err Secs, 3 Degraded Mins,
44336 Errored Secs, 2 Bursty Err Secs, 0 Severely Err Secs, 8438 Unavail Secs
T1 0/0/1 is down.
Applique type is Channelized T1
Cablelength is long 0db
Transmitter is sending remote alarm.
Receiver has loss of signal.
alarm-trigger is not set
Soaking time: 3, Clearance time: 10
AIS State:Clear LOS State:Failure LOF State:Failure
Version info Firmware: 20100222, FPGA: 13, spm_count = 0
Framing is ESF, Line Code is B8ZS, Clock Source is Line.
CRC Threshold is 320. Reported from firmware is 320.
Data in current interval (536 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 536 Unavail Secs
Total Data (last 24 hours)
9 Line Code Violations, 0 Path Code Violations,
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 86400 Unavail Secs
T1 0/1/0 is down.
Applique type is Channelized T1
Cablelength is long 0db
Transmitter is sending remote alarm.
Receiver has loss of signal.
alarm-trigger is not set
Soaking time: 3, Clearance time: 10
AIS State:Clear LOS State:Failure LOF State:Failure
Version info Firmware: 20100222, FPGA: 13, spm_count = 0
Framing is ESF, Line Code is B8ZS, Clock Source is Line.
CRC Threshold is 320. Reported from firmware is 320.
Data in current interval (542 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 542 Unavail Secs
Total Data (last 24 hours)
0 Line Code Violations, 0 Path Code Violations,
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 86400 Unavail Secs
T1 0/1/1 is down.
Applique type is Channelized T1
Cablelength is long 0db
Transmitter is sending remote alarm.
Receiver has loss of signal.
alarm-trigger is not set
Soaking time: 3, Clearance time: 10
AIS State:Clear LOS State:Failure LOF State:Failure
Version info Firmware: 20100222, FPGA: 13, spm_count = 0
Framing is ESF, Line Code is B8ZS, Clock Source is Line.
CRC Threshold is 320. Reported from firmware is 320.
Data in current interval (543 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 543 Unavail Secs
Total Data (last 24 hours)
0 Line Code Violations, 0 Path Code Violations,
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 86400 Unavail Secs
Router# show voice port summary
IN OUT
PORT CH SIG-TYPE ADMIN OPER STATUS STATUS EC
=============== == ============ ===== ==== ======== ======== ==
0/0/0:23 01 isdn-voice up dorm none none y
0/0/0:23 02 isdn-voice up dorm none none y
0/0/0:23 03 isdn-voice up dorm none none y
0/0/0:23 04 isdn-voice up dorm none none y
0/0/0:23 05 isdn-voice up dorm none none y
0/0/0:23 06 isdn-voice up dorm none none y
0/0/0:23 07 isdn-voice up dorm none none y
0/0/0:23 08 isdn-voice up dorm none none y
0/0/0:23 09 isdn-voice up dorm none none y
0/0/0:23 10 isdn-voice up dorm none none y
0/0/0:23 11 isdn-voice up dorm none none y
0/0/0:23 12 isdn-voice up dorm none none y
0/0/0:23 13 isdn-voice up dorm none none y
0/0/0:23 14 isdn-voice up dorm none none y
0/0/0:23 15 isdn-voice up dorm none none y
0/0/0:23 16 isdn-voice up dorm none none y
0/0/0:23 17 isdn-voice up dorm none none y
0/0/0:23 18 isdn-voice up dorm none none y
0/0/0:23 19 isdn-voice up dorm none none y
0/0/0:23 20 isdn-voice up dorm none none y
0/0/0:23 21 isdn-voice up dorm none none y
0/0/0:23 22 isdn-voice up dorm none none y
0/0/0:23 23 isdn-voice up dorm none none y
0/2/0 -- fxs-ls up dorm on-hook idle y
0/2/1 -- fxs-ls up dorm on-hook idle y
0/2/2 -- fxs-ls up dorm on-hook idle y
0/2/3 -- fxs-ls up dorm on-hook idle y
0/3/0 -- fxo-ls up dorm idle on-hook y
0/3/1 -- fxo-ls up dorm idle on-hook y
50/0/1 1 efxs up up on-hook idle y
50/0/1 2 efxs up up on-hook idle y
50/0/2 1 efxs up up on-hook idle y
50/0/2 2 efxs up up on-hook idle y
PWR FAILOVER PORT PSTN FAILOVER PORT
================= ==================
Router#show dial-peer voice summary
dial-peer hunt 0
AD PRE PASS OUT
TAG TYPE MIN OPER PREFIX DEST-PATTERN FER THRU SESS-TARGET STAT PORT
1001 pots up up 1001 0 up 0/2/0
2001 pots up up 2001 0 up 0/2/1
1 voip down down [2-9]..[2-9]....- 0 syst sip-server
..
2 voip down down 1[2-9]..[2-9]...- 0 syst sip-server
...
3 voip down down 7...... 0 syst sip-server
100 pots up up 0 down 0/2/1
20001 pots up up 5035550001$ 0 50/0/1
20002 pots up up 5035550002$ 0 50/0/2
11 pots up up [2-9]..[2-9]....- 0 down 0/0/0:23
..
12 pots up up 1[2-9]..[2-9]...- 0 down 0/0/0:23
...
13 pots up up 7...... 0 down 0/0/0:23
CUCME(PBX)
Code:
hostname Router
!
boot-start-marker
boot system usbflash1:
boot system usbflash1:c2800nm-adventerprisek9-mz.124-25g.bin
boot-end-marker
!
card type t1 0 3
!
no aaa new-model
network-clock-participate wic 2
network-clock-participate wic 3
!
!
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
isdn switch-type primary-ni
!
voice-card 0
no dspfarm
!
!
!
voice service pots
!
voice service voip
allow-connections sip to sip
sip
!
!
!
!
!
!
!
!
!
!
!
!
!
username **** privilege 15 secret ****
archive
log config
hidekeys
!
!
controller T1 0/2/0
framing esf
linecode b8zs
!
controller T1 0/2/1
framing esf
linecode b8zs
!
controller T1 0/3/0
framing esf
clock source internal
linecode b8zs
cablelength short 110
pri-group timeslots 1-24
description ***DOWNLINK TO PBX***
!
controller T1 0/3/1
framing esf
linecode b8zs
cablelength long 0db
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 192.168.1.249 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/3/0:23
no ip address
encapsulation hdlc
no logging event link-status
isdn switch-type primary-ni
isdn timer T306 30000
isdn timer T310 40000
isdn timer T321 30000
isdn protocol-emulate network
isdn incoming-voice voice
isdn guard-timer 1000
isdn send-alerting
no fair-queue
no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
!
ip http server
ip http authentication local
no ip http secure-server
ip http path usbflash1:/CUCME/gui
!
!
!
!
control-plane
!
!
!
voice-port 0/3/0:23
no non-linear
playout-delay maximum 120
playout-delay nominal 15
playout-delay minimum low
busyout monitor GigabitEthernet0/0
!
!
!
!
!
dial-peer voice 1 voip
description *** 10 Digit Calls ***
destination-pattern [2-9]..[2-9]......
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 2 voip
description *** 11 Digit Calls ***
destination-pattern 1[2-9]..[2-9]......
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 3 voip
description *** Lab Extensions ***
destination-pattern 7......
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 100 pots
description *** Incoming Dial-Peer ***
incoming called-number .
direct-inward-dial
port 0/3/0:23
!
dial-peer voice 1001 pots
destination-pattern 1001
no digit-strip
direct-inward-dial
port 0/3/0:23
forward-digits all
!
sip-ua
credentials username **** password **** realm sip-ua.com
authentication username **** password ****
registrar dns:proxy.sip-ua.com expires 60
sip-server dns:proxy.sip-ua.com
!
!
!
!
telephony-service
max-ephones 24
max-dn 48
ip source-address 192.168.1.250 port 2000
auto assign 1 to 48
timeouts interdigit 2
system message Portland Site (PBX)
url services http://phone-xml.berbee.com/menu.xml
create cnf-files version-stamp Jan 01 2002 00:00:00
max-conferences 8 gain -6
web admin system name **** secret ****
dn-webedit
time-webedit
transfer-system full-consult
!
!
line con 0
line aux 0
line vty 0 4
login local
line vty 5 15
login local
!
scheduler allocate 20000 1000
ntp clock-period 17180260
ntp server 64.250.229.100
!
end
Router# show controller t1
T1 0/2/0 is down.
Applique type is Channelized T1
Cablelength is long gain36 0db
Transmitter is sending remote alarm.
Receiver has loss of signal.
alarm-trigger is not set
Soaking time: 3, Clearance time: 10
AIS State:Clear LOS State:Clear LOF State:Clear
Version info Firmware: 20090113, FPGA: 20, spm_count = 0
Framing is ESF, Line Code is B8ZS, Clock Source is Line.
CRC Threshold is 320. Reported from firmware is 320.
Data in current interval (594 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 594 Unavail Secs
Total Data (last 24 hours)
16 Line Code Violations, 2456 Path Code Violations,
1 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins,
1 Errored Secs, 0 Bursty Err Secs, 2 Severely Err Secs, 83218 Unavail Secs
T1 0/2/1 is down.
Applique type is Channelized T1
Cablelength is long gain36 0db
Transmitter is sending remote alarm.
Receiver has loss of signal.
alarm-trigger is not set
Soaking time: 3, Clearance time: 10
AIS State:Clear LOS State:Clear LOF State:Clear
Version info Firmware: 20090113, FPGA: 20, spm_count = 0
Framing is ESF, Line Code is B8ZS, Clock Source is Line.
CRC Threshold is 320. Reported from firmware is 320.
Data in current interval (595 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 595 Unavail Secs
Total Data (last 24 hours)
1 Line Code Violations, 0 Path Code Violations,
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 86400 Unavail Secs
T1 0/3/0 is up.
Applique type is Channelized T1
Cablelength is short 110
Description: ***DOWNLINK TO PBX***
No alarms detected.
alarm-trigger is not set
Soaking time: 3, Clearance time: 10
AIS State:Clear LOS State:Clear LOF State:Clear
Version info Firmware: 20090408, FPGA: 13, spm_count = 0
Framing is ESF, Line Code is B8ZS, Clock Source is Internal.
CRC Threshold is 320. Reported from firmware is 320.
Data in current interval (857 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
165 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
165 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
Total Data (last 86 15 minute intervals):
522 Line Code Violations, 1 Path Code Violations,
30663 Slip Secs, 1 Fr Loss Secs, 2 Line Err Secs, 1 Degraded Mins,
30664 Errored Secs, 0 Bursty Err Secs, 1 Severely Err Secs, 2753 Unavail Secs
T1 0/3/1 is down.
Applique type is Channelized T1
Cablelength is long 0db
Transmitter is sending remote alarm.
Receiver has loss of signal.
alarm-trigger is not set
Soaking time: 3, Clearance time: 10
AIS State:Clear LOS State:Clear LOF State:Clear
Version info Firmware: 20090408, FPGA: 13, spm_count = 0
Framing is ESF, Line Code is B8ZS, Clock Source is Line.
CRC Threshold is 320. Reported from firmware is 320.
Data in current interval (857 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 857 Unavail Secs
Total Data (last 86 15 minute intervals):
4 Line Code Violations, 0 Path Code Violations,
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 77400 Unavail Secs
Router# show voice port sum
IN OUT
PORT CH SIG-TYPE ADMIN OPER STATUS STATUS EC
=============== == ============ ===== ==== ======== ======== ==
0/3/0:23 01 isdn-voice up dorm none none y
0/3/0:23 02 isdn-voice up dorm none none y
0/3/0:23 03 isdn-voice up dorm none none y
0/3/0:23 04 isdn-voice up dorm none none y
0/3/0:23 05 isdn-voice up dorm none none y
0/3/0:23 06 isdn-voice up dorm none none y
0/3/0:23 07 isdn-voice up dorm none none y
0/3/0:23 08 isdn-voice up dorm none none y
0/3/0:23 09 isdn-voice up dorm none none y
0/3/0:23 10 isdn-voice up dorm none none y
0/3/0:23 11 isdn-voice up dorm none none y
0/3/0:23 12 isdn-voice up dorm none none y
0/3/0:23 13 isdn-voice up dorm none none y
0/3/0:23 14 isdn-voice up dorm none none y
0/3/0:23 15 isdn-voice up dorm none none y
0/3/0:23 16 isdn-voice up dorm none none y
0/3/0:23 17 isdn-voice up dorm none none y
0/3/0:23 18 isdn-voice up dorm none none y
0/3/0:23 19 isdn-voice up dorm none none y
0/3/0:23 20 isdn-voice up dorm none none y
0/3/0:23 21 isdn-voice up dorm none none y
0/3/0:23 22 isdn-voice up dorm none none y
0/3/0:23 23 isdn-voice up dorm none none y
PWR FAILOVER PORT PSTN FAILOVER PORT
================= ==================
Router#show dial-peer voice summary
dial-peer hunt 0
AD PRE PASS OUT
TAG TYPE MIN OPER PREFIX DEST-PATTERN FER THRU SESS-TARGET STAT PORT
1 voip up up [2-9]..[2-9]....- 0 syst sip-server
..
2 voip up up 1[2-9]..[2-9]...- 0 syst sip-server
...
3 voip up up 7...... 0 syst sip-server
100 pots up up 0 down 0/3/0:23
1001 pots up up 1001 0 down 0/3/0:23
Router#wr
Building configuration...
[OK]
Router#exit
Statistics: Posted by javin — Fri Feb 14, 2014 10:51 pm