I just got my LSI SAS9220-8i / M1015, and I have some experiences to share with others, because, along with the crossflashing, this card had me pulling my hair out.

My system specs for my gaming / media PC are:

Gigabyte Z77X-UD5H

Corsair Dominator DDR3 1600 Ram (16GB)

Gigabyte GTX470 SOC

Antec HCP1200

(2) LG Blu Ray Burners

(2) Icy Dock 3 in 2 trayless drive cages.

I received this card from China, after purchasing it on eBay. It came within about 10 days, and during this time I was daydreaming about how sweet it was going to be when I put it into my computer, and then I could use all of my IcyDock 3 in 2 enclosures, I have 2 of them, and also 2 Blu Ray burners.

I had been unsatisfied with the fact that when I had the drive cages plugged into the motherboard sata ports, and I plugged a new drive into the cage, it would shut down the other drive connected to the same controller, and then reinitialize them both. If I was playing a movie from one hard drive, and plugged in a new drive, the movie would stop playing; I am finicky this way.

At first I was mad at IcyDock, because I thought it was a power related issue, but when the same problem happened with different power cables, I ruled that out. I racked my brains and in a fit of genius, I connected each port of the drive cage to a different controller, i.e, the OS drive to the Intel 6GBs controller, and the second drive to the Marvell 6GBs controller, and the third drive to the Marvell 3GBs controller. This solved the problem, and began my search for a new controller card.

I had read about the legendary M1015 in IT mode, and I began looking for one on eBay. I found one in China, for about $107 dollars with free shipping, but about a 15 day wait. During this time, I had been looking forward to getting this thing installed, and in my head it would work so perfectly. "I will put in in this slot," I told myself, as I stared down into my computer case, and I would plug it into all these components, and it would go so flawlessly.


I had read these forums, and others, and thought I knew everything there was to know about installing and crossflashing the M1015. I had my USB key loaded with the requisite files, I had updated my BIOS to the latest firmware I could get from this forum, I had even went through my computer and done cable management in preparation for running the forward breakout cables; "I am ready," I told myself.

I got the card yesterday, and ran downstairs to my computer room, and slammed the door shut. I opened the taped package in a fit of joy, knife in hand, eyes wide; I was a kid on Christmas morn. I threw the instruction book, and CD to the side, pulled my computer from is rack, and opened it up. I popped the M1015 into the second PCI-E slot, an X8 slot, according to Newegg, and my manual. I had read of others having problems with this card not working in this slot, but I thought an updated BIOS would have fixed the problem. My delight soon turned to dismay, as I learned that the card would not function in this slot even with the updated BIOS, I was upset. Windows booted, and there in Device Manager, there was no sign of my precious M1015. I knew this was a possibility, I relocated my GPU to the second slot, and the M1015 to the first.

"YES!," I roared, as I booted my computer, and the LSI bios came up, I had not received a dead unit from the far east. With crossflashing next on my list I plugged in the USB key, and rebooted my machine. I was in MS DOS and running the megarec commands, without so much as a care, until I got the sas2flsh PAL error. I had thought if I made it through megarec, surely sas2flsh would work fine, that was not the case. So now I had a firmware-less card, and I had to find a way to fix it. I booted back into Windows, and formatted the key again, this time placing updated efi files onto it, hoping, against all hope, that this would work. I rebooted, and tried to get my Z77X into an EFI shell. Over the next 4 hours, I received bootdisk errors, or I would select UEFI as the boot option, and then be greeted with the MS DOS prompt, or load into Windows after selecting UEFI on my key, I was straddling frustration and anger, I was on the raggedy edge. I did manage to make it into the UEFI shell three times, but never with the card installed, for some reason as soon as the card was in place, the Gods decided, that I would not be blessed with a UEFI shell. I tried everything; shellx64.efi, bootx64.efi, /efi/boot directories, formatting in GPT for UEFI, formatting in MBR for UEFI, MBR for both, nothing was working. Dinner was ready, still in my pajamas, I said very little at the supper table, I was crest-fallen.

I gave up the effort on my main machine, and began looking for a suitable alternative. I had my "still waiting on parts" NAS server. I have another M1015 coming for this machine, so I thought I would try to flash the card in it; I pulled it from the rack, and opened it up. This machine has my old ASUS P5G41 M LE, with a quad core 2.5GHz processor and 4GB of RAM. I had tested this machine without the M1015, and it would boot to BIOS but it didn't have the hard drives attached, so no OS. I had planned this machine out very well, or so I thought. I was using the onboard graphics, no need for a GPU, so my PCI-E X16 slot was free. I plugged the M1015 into to the PCI-E slot, and the computer refused to post. "Crap," I thought, I tried numerous BIOS options, but it was no use. I will have to upgrade the motherboard, CPU, and RAM for this machine before I can use it as a NAS with the M1015.

I was down to my last resort, the final solution. I waited patiently until my wife and children were asleep, then I stalked my quarry. I crept quietly into her office, and began unplugging the cables from the back of her beloved machine. I carried it into my office, and laid it on the table, where I would preform my delicate operation. I plugged in all my accessory cables and installed my M1015 into it, then plugged in the power, and turned it on. I was greeted with the MS DOS prompt, where I began with the megarec command. I had been through this before, so I held my breath on the reboot. I entered the sas2flsh commands as I prayed under my breath. My prayers are answered as I see the LSI flashing echos, and then success!

All is smooth for the rest of the flash, and I remove the card from her PC and quietly put it back in its place.

I put the M1015 back into my primary PCI-E slot, and plug in the forward breakout cables. One of my hopes for this card was that I would be able to boot from it, that way all my drives are run through this card, so I flashed the M1015 with the IT firmware, and the ROM. I tried to boot Windows from the card, but I get to the Starting Windows screen and the computer reboots, infinitely if I don't stop it. I may try installing Windows on another hard drive with the controller and see if that works, but my hopes are not high, I was prepared for it, and I can just plug the first drive in the cage, and the BD drive into the Intel controller on the board.

I am not pleased with the wait time at the LSI screen when I start my computer, so I will remove the ROM tonight, and make it a plain, dumb HBA, instead. What really grinds my gears is the PCI slot issue with my motherboard, and the PCI slot issue with my NAS motherboard. I am looking for ways to solve these issues, but I have already ordered a Gigabyte GA-Z68MX-UD2H-B3 Socket 1155 Motherboard off of eBay, to replace the one in my NAS, hopefully that one will work as desired.

The issue with the PCI-E Slot in my main computer is not that big of a deal, as that motherboard, CPU, and RAM were purchased to tide me over, until the X99 chipset comes out later this year. Hopefully that chipset will work with the M1015 better than my GA-Z77X-UD5H does, but I will wait until I hear confirmed reports of the compatibility before I purchase it. I am not even that upset about the M1015 not working in my NAS, as that gave me a chance to upgrade it for future proofing, and the replacement parts only cost about $240, not a big deal. The motherboard I purchased was an impulse buy on eBay, but there is anecdotal evidence that the M1015 does work in it.

The M1015 works great, even though it resides in the primary PCI-E slot. I am able to remove drives and re install drives effortlessly. I put a drive in the system, and count backwards from 10, and by the time I reach 1, the drive is in My Computer, ready for use. Using Zentimo Storage Manager, I am able to stop and eject these drives, before removal. I did have a bit of a sphincter clench when Zentimo, kept unassigning my Movie drive, its drive letter. The drive showed up as healthy in Disk Management, but remained unseen in My Computer. Every time I would assign it a drive letter, it would be removed. I figured out that Zentimo was unassigning it for some reason, so I uninstalled Zentimo. I then assigned a drive letter to the drive, and it showed up again, with all my movies intact, a big relief to me, because it was a great deal of work to get them there in the first place.

The primary PCI-E slot issue, is OK, because I rarely play GPU intense games, and from what I have read, there is little more than a 2 fps difference, between the X16 and the X8 PCI-E slots.

My story is finished, please comment below.

Show more